討論區: ヘルプ (Thread #48736)

Escape sequences used with Ctrl in bindkey doesn't have an affect (2023-03-04 14:35 by sewn #94414)

Hi, i am a new user of the yash(1) shell and i am enjoying it very much. I've noticed that in current emacs bindkey configuration Ctrl + Left arrow and Ctrl + Right arrow do not do anything, as in other shell they go forward and backword in word. i try to get this behavior back with the following:

bindkey --emacs '\^\R' forward-viword
bindkey --emacs '\^\L' backward-viword

But it does not have an affect. I have verified this by using any of the escape sequences in the manual page (\X, \H, \N, \P, \E, \H, \B, etc.) with Ctrl (\^) but they do not have an affect either.

Is this a bug with yash itself or something else?

For more information: I am running st(1) terminal emulator (attempted with alacritty terminal emulator), and the yash build flags are:

./configure \
--prefix=/usr \
--prefix=/usr \
--enable-help \
--enable-printf \
--enable-socket \
--enable-ulimit \
--enable-history \
--enable-lineedit \
--disable-nls

Thank you for your help.

回覆 #94414×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) 登入

Re: Escape sequences used with Ctrl in bindkey doesn't have an affect (2023-03-24 00:55 by magicant #94719)

Did you see ticket #46524? If not, try the command posted on the ticket.
https://osdn.net/projects/yash/ticket/46524
回覆: #94414

回覆 #94719×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) 登入