[Mingw-users] Support AX_CXX_COMPILE_STDCXX_11 macro in autoconf

Anton Shepelev anton****@gmail*****
Sun Jan 19 06:33:48 JST 2020


Keith Marshall to Anton Shepelev:

> I don't see you running autoconf, to regenerate the
> configure script...

I am sorry, but I neglected to run it.  I feel intimidated
by the huge and complicated build systems and their scripts
with which I have to deal it when contribuing to third-party
projects.  When, however, I deleted `configure' and I re-
generated it with `./autogen.sh', nothing changed.  I had a
warning about another macro:

   configure.ac:215: warning: macro `AM_PATH_ALSA' not found in library

which is indeed missing from my system, but it said nothing
about AX_CXX_COMPILE_STDCXX_11.  Yet, it still is there in
the generated script, unexpanded.

> Did you regenerate the configure script _after_ you copied
> the m4 macro definition to your aclocal directory?  The
> diagnostic suggests that you didn't.

Now I did.

> I don't see any mention of an autoconf version constraint,
> in the documentation, to which you refer, for
> AX_CXX_COMPILE_STDCXX_11; what makes you think that there
> may be one?

I thought so because it didn't work after I "installed" this
macro into /usr/share/aclocal/ .

Now that I have regenerated the configuration script, seen
no warning about this macro, and it has remained unexpanded,
I don't know what to suggest.  I have made sure my
`autogen.sh' invokes `autoconf'.



More information about the MinGW-Users mailing list