[Mingw-users] MinGW installer errors

David Gressett DGres****@amli-*****
Sat Jan 11 00:26:44 JST 2020


I opend the installer and updated the catalogue.
Marking all upgrades caused an error box to pop up:

Internal package specification error
libminizip-1.2.7-1-mingw32.dll-1.tar.lzma: requires...
mingw32-libz-%-mingw32-dll-1.tar: unresolved dependency
(type 'eq')
mingw32-libz-%-mingw32-dll-1.tar: cannot identify any
providing package

mingw32-libminizip-dev
mingw32-libminizip-dll
were not installed.

I marked them for installation. I expected a failure,
anf got one, but the error message was not very informative:

Internal package specification error
can't get tarname for non-release elelemt
<<<unknown>>>
please report this to the package maintainer

The libminizip dll package  installed; the dev package failed.

a second attemt to install the dev package produced a repetition
of the original package specification error message.

An attempt to close the installer produces a message telling me 
that there are uninstalled upgrades. 
An attempt to install them produces this message:

Not all changes were applied successfully; please refer to details below.

Details:
install: libz-1.2.11-1-mingw32-dll-1.tar.xz
 installing libz-1.2.11-1-mingw32-dll-1.tar.xz
upgrade: libz-1.2.11-1-mingw32-dev.tar.xz
 removing release libz-1.2.11-1-mingw32-dev.tar.xz
upgrade: libz-1.2.11-1-mingw32-dev.tar.xz
 removing release libz-1.2.11-1-mingw32-dev.tar.xz
mingw-get-gui: *** ERROR *** libz-1.2.11-1-mingw32-dev.tar.xz: invalid manifest; no references
upgrade: libz-1.2.11-1-mingw32-dev.tar.xz
 removing release libz-1.2.11-1-mingw32-dev.tar.xz
mingw-get-gui: *** ERROR *** libz-1.2.11-1-mingw32-dev.tar.xz: invalid manifest; no references



More information about the MinGW-Users mailing list