討論區: 公開討議 (Thread #35330)

Warning message (BASICAcc). (2014-04-18 10:23 by giorgos #72670)

Hi! :-)

I just run BASICAcc on Debian Wheezy (the stable version) x64 KDE and (when I execute a compiled program) I keep getting this message:
"(NoName:3424): Gdk-CRITICAL **: IA__gdk_drawable_get_size: assertion `GDK_IS_DRAWABLE (drawable)' failed"

Any ideas?
TIA! :-)
G.

回覆 #72670×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) 登入

Re: Warning message (BASICAcc). (2014-04-18 15:07 by SHIRAISHI Kazuo #72674)

The library for BASICAcc 0.9.7.0 Linux64 depends on GTK2.0.
Linux KDE runs without GTK2, so I wonder it lacks GTK2 libraies.
Is your Lazarus original ?
If Lazarus has been installed via linux distributor's repository, this may happen.
回覆: #72670

回覆 #72674×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) 登入

Re: Warning message (BASICAcc). (2014-04-19 04:49 by giorgos #72683)

[Reply To Message #72674]
> The library for BASICAcc 0.9.7.0 Linux64 depends on GTK2.0.
> Linux KDE runs without GTK2, so I wonder it lacks GTK2 libraies.
> Is your Lazarus original ?
> If Lazarus has been installed via linux distributor's repository, this may happen.

I installed the official DEB installers from SF.NET, but I tried also the repository version, and brings up the same warning message.

I think GTK2 runtimes are at prerequisites, but I'm not sure because I have them installed here, from earlier (even the development ones).

Anyway! Since it's an FPC problem (not a BASICAcc one) I may ask at FPC forum.
THANKS!!! :-)
回覆: #72674

回覆 #72683×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) 登入

Re: Warning message (BASICAcc). (2014-04-19 16:48 by SHIRAISHI Kazuo #72691)

I confirmed that Kubuntu 14.04 (amd64) + lazarus 1.2.0 allows BASICAcc to work properly. The problem may not concern KDE.


回覆: #72683

回覆 #72691×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) 登入